summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c079f8880911
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Kevin MacMartin <prurigro at gmail dot com>
+
+_pkgname=hellcat
+pkgname=${_pkgname}-git
+pkgver=r45.8873f05
+pkgrel=1
+pkgdesc="netcat that takes unfair advantage of traffic shaping systems that don't initially ratelimit"
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
+url="https://github.com/matildah/hellcat"
+license=('MIT')
+depends=('glibc')
+makedepends=('clang' 'git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+replaces=("$_pkgname")
+
+source=("git://github.com/matildah/${_pkgname}.git#branch=master"
+ "${_pkgname}-build.patch")
+sha512sums=('SKIP'
+ 'e5f697b5ffba48dbc7d88caa286e02dc59f1fdea0a889b32df64cf6dfd2bae62dcc4b7223fb7fab7d7f6c89832f2fb7e8d87255944cfe1ff2cbd1c69a863397c')
+
+pkgver() {
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd $_pkgname
+ patch -p1 < ../${_pkgname}-build.patch
+}
+
+build() {
+ cd $_pkgname
+ make
+}
+
+package() {
+ cd $_pkgname
+ install -Dm755 hellrecv "${pkgdir}/usr/bin/hellrecv"
+ install -Dm755 hellsend "${pkgdir}/usr/bin/hellsend"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}