summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 13 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f2855cf416f6..a5d9914da280 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,35 @@
# Maintainer: ml <ml@visu.li>
pkgname=helm-edit
-pkgver=0.4.0
-pkgrel=2
+pkgver=0.5.0
+pkgrel=1
pkgdesc='Helm plugin to edit releases'
arch=('x86_64')
url='https://github.com/mstrzele/helm-edit'
license=('MIT')
install=helm-edit.install
-depends=('bash' 'helm>=3.0.0')
+depends=('bash' 'helm')
makedepends=('go')
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('97a0bb6573f886738665de6c3ff355debf541378dfe01443bf456bc60778c6aa')
+source=("$url/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('60d13996dc075310f8f4bcd9641ddacc9d3facbb14176fa3e6ceb25a8ce6d1c1')
prepare() {
- cd "${pkgname}-${pkgver}"
- #go mod download
- go mod tidy # required for -mod=readonly due to missing checksums
- sed -i '/^hooks:$/Q' plugin.yaml
+ sed -i '/^hooks:$/Q' "$pkgname-$pkgver"/plugin.yaml
}
build() {
- cd "${pkgname}-${pkgver}"
+ cd "$pkgname-$pkgver"
export CGO_ENABLED=1
export CGO_LDFLAGS="$LDFLAGS"
export CGO_CFLAGS="$CFLAGS"
export CGO_CPPFLAGS="$CPPFLAGS"
export CGO_CXXFLAGS="$CXXFLAGS"
- export GOFLAGS='-buildmode=pie -trimpath -modcacherw -mod=readonly'
- go build -o helm-edit
+ export GOFLAGS='-buildmode=pie -trimpath -modcacherw'
+ go build -o "$pkgname"
}
package() {
- cd "${pkgname}-${pkgver}"
- install -Dm755 helm-edit -t "${pkgdir}/usr/lib/helm/plugins/${pkgname##helm-}"
- install -m644 plugin.yaml -t "${pkgdir}/usr/lib/helm/plugins/${pkgname##helm-}"
- install -m755 plugin.complete -t "${pkgdir}/usr/lib/helm/plugins/${pkgname##helm-}"
- install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ cd "$pkgname-$pkgver"
+ install -Dm755 helm-edit plugin.complete -t "$pkgdir"/usr/lib/helm/plugins/edit
+ install -m644 plugin.yaml -t "$pkgdir"/usr/lib/helm/plugins/edit
+ install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/"$pkgname"
}