summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 24 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d24977430f94..44418da92f70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=helm
pkgname="${_pkgname}-git"
-pkgver=0.5.0.r1105.ad798d4
+pkgver=0.8.5.r1458.6dbcd64
pkgrel=1
pkgdesc="a cross-platform, polyphonic synthesizer LV2 and VST plugin"
arch=('i686' 'x86_64')
@@ -10,19 +10,33 @@ url="http://tytel.org/helm/"
license=('GPL')
groups=('lv2-plugins' 'vst-plugins')
depends=('alsa-lib' 'freetype2' 'mesa' 'lv2')
-makedepends=('git')
+makedepends=('git' 'steinberg-vst36')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=("${_pkgname}::git+https://github.com/mtytel/helm.git"
- 'http://www.steinberg.net/sdk_downloads/vstsdk360_22_11_2013_build_100.zip')
-md5sums=('SKIP'
- '1ac422ebb4aa2e86061278412c347b55')
+source=("${_pkgname}::git+https://github.com/mtytel/helm.git")
+md5sums=('SKIP')
changelog=ChangeLog
prepare() {
- cd "$srcdir/${_pkgname}/builds/linux/VST"
- sed -i -e "s|-I ~/srcs/VST3\\\\ SDK|-I $srcdir/VST3\\\\ SDK|" Makefile
+ cd "$srcdir/${_pkgname}"
+
+ msg2 "Fixing Makefiles..."
+ sed -i -e "s|-I ~/srcs/VST3\\\\ SDK||" \
+ builds/linux/VST/Makefile
+
+ for build in standalone/builds/linux builds/linux/VST builds/linux/LV2; do
+ sed -i -e 's|JUCE_INCLUDE_PNGLIB_CODE=0|JUCE_INCLUDE_PNGLIB_CODE=1|g' \
+ "$build/Makefile"
+ done
+
+ msg2 "Fixing VST3 SDK include paths in JUCE sources..."
+ for file in \
+ JUCE/extras/Introjucer/Source/Utility/jucer_StoredSettings.cpp \
+ JUCE/modules/juce_audio_plugin_client/VST/juce_VST_Wrapper.cpp \
+ JUCE/modules/juce_audio_processors/format_types/juce_VST3Headers.h; do
+ sed -i -e 's|public.sdk/source/vst2.x|vst36|g' "$file"
+ done
}
pkgver() {
@@ -36,12 +50,14 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
+ CXXFLAGS="${CXXFLAGS} -DHAVE_LROUND"
make PREFIX="/usr" all vst
}
package() {
cd "${srcdir}/${_pkgname}"
+ CXXFLAGS="${CXXFLAGS} -DHAVE_LROUND"
make DESTDIR="$pkgdir" install
install -D builds/linux/VST/build/helm.so "$pkgdir/usr/lib/vst/helm.so"
}