summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e63922a182f..25f59a496c67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,29 @@
pkgname=hererocks
pkgver=0.25.1
-pkgrel=1
+pkgrel=2
pkgdesc="Tool for installing Lua and LuaRocks locally"
-arch=('any')
+arch=(any)
url="https://github.com/luarocks/hererocks"
-license=('MIT')
-depends=('python')
-makedepends=('python-setuptools')
+license=(MIT)
+depends=(
+ python-setuptools
+ python-importlib-metadata
+)
+
source=("$pkgname-$pkgver.tar.gz::https://github.com/luarocks/$pkgname/archive/refs/tags/$pkgver.tar.gz")
sha256sums=('bd3769fb9f7ac944f67601575a6c0aad7118e89ebba418985a126c2412f1f9e0')
+_archive="$pkgname-$pkgver"
+
build() {
- cd "$pkgname-$pkgver"
+ cd "$_archive"
python setup.py build
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$_archive"
export PYTHONHASHSEED=0
python setup.py install --root="$pkgdir" --optimize=1 --skip-build