summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 5 insertions, 37 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4521d30e60c1..4fd3c07017a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
_pkgname=Herwig
pkgname=herwig
-pkgver=7.0.4
-pkgrel=4
+pkgver=7.1.0
+pkgrel=1
pkgdesc="Herwig is a multi-purpose particle physics event generator."
arch=('i686' 'x86_64')
url="http://herwig.hepforge.org"
license=('GPL2')
-depends=("gcc-fortran" "thepeg>=2.0.4" "fastjet" "gsl" "boost-libs" "lhapdf")
-makedepends=("sed" "sudo")
+depends=("gcc-fortran" "thepeg>=2.1.0" "fastjet" "gsl" "boost-libs" "lhapdf")
+makedepends=("sudo" "sed")
source=("http://www.hepforge.org/archive/${pkgname}/${_pkgname}-${pkgver}.tar.bz2")
-sha256sums=('e6265f6cae2944b022ee2f1495b0abdd7ed1b50fdda81063f8c17acf8a2f4ced')
+sha512sums=('a18cd1a5a399789ceb019393df817b08540d1d37af55375a82c0436d46ee8c3e8e8da5fed12431af0b3194be23b2b7ad75834da037c977b6b157a752f1dd90bd')
prepare() {
pdfs=(MMHT2014nlo68cl MMHT2014lo68cl)
@@ -25,39 +25,7 @@ prepare() {
done
cd "$srcdir/${_pkgname}-${pkgver}"
-
sed -i 's/lib\/libgsl.a/lib\/libgsl.so/' configure
- sed -i 's/isnan/std::isnan/g' Decay/Radiation/FFDipole.cc \
- Decay/Radiation/IFDipole.cc \
- PDF/MRST.cc \
- Shower/Default/QTildeReconstructor.cc \
- DipoleShower/Base/DipoleSplittingGenerator.cc \
- DipoleShower/DipoleShowerHandler.cc \
- MatrixElement/Powheg/MEqq2W2ffPowheg.cc \
- MatrixElement/Powheg/MEPP2WHPowheg.cc \
- MatrixElement/Powheg/MEqq2gZ2ffPowheg.cc \
- MatrixElement/Powheg/MEPP2ZHPowheg.cc \
- MatrixElement/Powheg/MEPP2VVPowheg.cc \
- MatrixElement/Matchbox/Base/MatchboxMEBase.cc \
- MatrixElement/Matchbox/Utility/ColourBasis.cc \
- Analysis/BasicConsistency.cc \
- Sampling/GeneralStatistics.h \
- Sampling/GeneralSampler.cc \
- Sampling/MonacoSampler.cc \
- Sampling/BinSampler.cc
- sed -i 's/isinf/std::isinf/g' PDF/MRST.cc \
- DipoleShower/Base/DipoleSplittingGenerator.cc \
- MatrixElement/Powheg/MEqq2W2ffPowheg.cc \
- MatrixElement/Powheg/MEPP2WHPowheg.cc \
- MatrixElement/Powheg/MEqq2gZ2ffPowheg.cc \
- MatrixElement/Powheg/MEPP2ZHPowheg.cc \
- MatrixElement/Powheg/MEPP2VVPowheg.cc \
- MatrixElement/Matchbox/Base/MatchboxMEBase.cc \
- Analysis/BasicConsistency.cc \
- Sampling/GeneralStatistics.h \
- Sampling/GeneralSampler.cc \
- Sampling/MonacoSampler.cc \
- Sampling/BinSampler.cc
}
build() {