summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5e675b19dd1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+
+pkgname=hexchat-indicator
+pkgver=3
+pkgrel=1
+pkgdesc="Unity Application Indicator for HexChat (Bazaar version)"
+arch=('i686' 'x86_64')
+url="https://launchpad.net/hexchat-indicator/trunk"
+license=('GPL')
+depends=('indicator-messages' 'libunity')
+makedepends=('bzr')
+source=('hexchat-indicator::bzr+lp:hexchat-indicator')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd hexchat-indicator
+ echo "$(bzr revno)"
+}
+
+build() {
+ cd hexchat-indicator
+ autoreconf -vfi
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd hexchat-indicator
+ make DESTDIR="${pkgdir}/" install
+}