summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d2a7d51cf387..740776a69ae1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,14 +9,21 @@ arch=('i686' 'x86_64')
#url="http://directory.fsf.org/project/HexCurse/"
url="https://github.com/LonnyGomes/hexcurse"
license=('GPL')
-depends=('ncurses>=5.6-7')
options=('!makeflags')
-source=("https://github.com/LonnyGomes/hexcurse/archive/v$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tgz::https://github.com/LonnyGomes/hexcurse/archive/v$pkgver.tar.gz")
#source=("http://www.sourcefiles.org/Editors/Hex/$pkgname-$pkgver.tar.gz")
#source=("http://gd.tuwien.ac.at/opsys/linux/gentoo/distfiles/$pkgname-$pkgver.tar.gz")
#source=("https://github.com/LonnyGomes/hexcurse/archive/hexcurse-$pkgver.tar.gz")
md5sums=('cb24b564bea21a615a5c6a2ee30d6cad')
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ # gcc does not like clever people
+ sed -i 's|buffer, 1,|NULL, 0,|' src/hexcurse.c
+ sed -i 's|char buffer\[1\];|//&|' src/hexcurse.c
+ sed -i 's|2*MAXY);|&\nbreak;|' src/acceptch.c
+}
+
build() {
cd "$srcdir/$pkgname-$pkgver"