summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ba2f5402d56
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: SpepS <dreamspepser at yahoo dot it>
+# Contributor: eric <eric@archlinux.org>
+
+pkgname=hexcurse
+pkgver=1.55
+pkgrel=3
+pkgdesc="Versatile ncurses-based hex editor."
+arch=('i686' 'x86_64')
+url="http://directory.fsf.org/project/HexCurse/"
+license=('GPL')
+depends=('ncurses>=5.6-7')
+options=('!makeflags')
+source=("http://gd.tuwien.ac.at/opsys/linux/gentoo/distfiles/$pkgname-$pkgver.tar.gz"
+ "hexcurse-alloca.patch")
+#source=("http://www.sourcefiles.org/Editors/Hex/$pkgname-$pkgver.tar.gz")
+md5sums=('c9f9485490300b5111aa429eabfef789'
+ 'fb7723bff0411392fe410839f6105e4f')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ patch -p0 < ../hexcurse-alloca.patch
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}