summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9ba2f5402d56..82f475a47739 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,26 @@
# Contributor: eric <eric@archlinux.org>
pkgname=hexcurse
-pkgver=1.55
-pkgrel=3
+pkgver=1.58
+pkgrel=1
pkgdesc="Versatile ncurses-based hex editor."
arch=('i686' 'x86_64')
-url="http://directory.fsf.org/project/HexCurse/"
+#url="http://directory.fsf.org/project/HexCurse/"
+url="https://github.com/LonnyGomes/hexcurse"
license=('GPL')
depends=('ncurses>=5.6-7')
options=('!makeflags')
-source=("http://gd.tuwien.ac.at/opsys/linux/gentoo/distfiles/$pkgname-$pkgver.tar.gz"
+source=("https://github.com/LonnyGomes/hexcurse/archive/hexcurse-$pkgver.tar.gz"
"hexcurse-alloca.patch")
#source=("http://www.sourcefiles.org/Editors/Hex/$pkgname-$pkgver.tar.gz")
-md5sums=('c9f9485490300b5111aa429eabfef789'
+#source=("http://gd.tuwien.ac.at/opsys/linux/gentoo/distfiles/$pkgname-$pkgver.tar.gz"
+md5sums=('26c3ccf56850ff030d5097ee4bbc2b0b'
'fb7723bff0411392fe410839f6105e4f')
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgname-$pkgver"
- patch -p0 < ../hexcurse-alloca.patch
+ #patch -p0 < ../hexcurse-alloca.patch
./configure \
--prefix=/usr \
@@ -29,7 +31,7 @@ build() {
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
}