summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c39ae7a306fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Antheas Kapenekakis <aur at antheas dot dev>
+pkgname=hhd-user
+pkgver=0.0.1
+pkgrel=1
+pkgdesc='Handheld Daemon User Service. Adds a user service file, and the appropriate rules so that hhd can run as a user daemon. Reboot and enable with `systemctl --user enable hhd-user`.'
+arch=('x86_64')
+url='https://github.com/antheas/hhd'
+license=('MIT')
+depends=()
+provides=()
+makedepends=( )
+source=( "hhd-user.conf" "83-hhd-user.rules" "hhd-user.service" )
+sha512sums=( 'SKIP' 'SKIP' 'SKIP' )
+
+package() {
+ # Install minimally necessary rules for running as a user service
+ mkdir -p ${pkgdir}/usr/lib/modules-load.d/
+ install -m644 hhd-user.conf ${pkgdir}/usr/lib/modules-load.d/hhd-user.conf
+ mkdir -p ${pkgdir}/usr/lib/udev/rules.d/
+ install -m644 83-hhd-user.rules ${pkgdir}/usr/lib/udev/rules.d/83-hhd-user.rules
+ mkdir -p ${pkgdir}/usr/lib/systemd/user/
+ install -m644 hhd-user.service ${pkgdir}/usr/lib/systemd/user/hhd-user.service
+} \ No newline at end of file