summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5d4bb5460196..cf62607c147f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,30 @@
# Contributor: juantascon <juantascon.aur@horlux.org>
# Contributor: Ilya Kuzmin <i.g.kuzmin.spb@gmail.com>
-pkgname='hid-apple-patched-git-dkms'
+pkgname=hid-apple-patched-git-dkms
_pkgname=hid-apple-patched
-pkgver=20200331.f7f6560
+pkgver=20200401.5ebf708
pkgrel=1
url="https://github.com/free5lot/hid-apple-patched"
arch=('any')
license=('GPL2')
-pkgdesc="Allows to swap the Fn key and left Control key on Macbook Pro and Apple keyboards in GNU/Linux (DKMS)"
+pkgdesc="Swaping the Fn and left Control keys and some other mapping tweaks on Macbook Pro and Apple keyboards (DKMS)"
-depends=('dkms')
+depends=('dkms' 'mkinitcpio-modconf-hook')
makedepends=('git')
install=hid-apple-patched-dkms.install
source=("git+https://github.com/free5lot/$_pkgname#branch=master"
- "hid-apple-patched.conf"
- "hid_apple_pclayout.conf"
+ "hid_apple.depmod"
+ "hid_apple.modprobe"
"dkms.conf")
sha256sums=('SKIP'
'4b94f1f55febddad5ff60a8918487b883ceadd4e6c3fb280e98e4e235cd09663'
- '2a493d3973b80b815779643b2c1039f52c05e2e9a65cebd00b2a1da105630cbb'
+ 'bf214ca80aa4abb6fe85c1108ea7c941684a5bc57891982b0aefafd5a6339a26'
'5d2457728a93e73a96f2ca88f66455859363f083097ad20e661bdc12dc44a9ba')
pkgver() {
@@ -44,6 +44,6 @@ package() {
-e "s/@PKGVER@/${pkgver}/" \
-i "${pkgdir}"/usr/src/${_pkgname}-${pkgver}/dkms.conf
- install -Dm644 hid_apple_pclayout.conf "${pkgdir}"/etc/modprobe.d/hid_apple_pclayout.conf
- install -Dm644 hid-apple-patched.conf "$pkgdir"/etc/depmod.d/hid-apple-patched.conf
+ install -Dm644 hid_apple.modprobe "${pkgdir}"/usr/lib/modprobe.d/hid_apple.conf
+ install -Dm644 hid_apple.depmod "${pkgdir}"/usr/lib/depmod.d/hid_apple.conf
}