summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a759f8fc4b58..ed5358eb9097 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Kieran Colford <kieran@kcolford.com>
pkgname=hidclient
-pkgver=20060725
+pkgver=20120728
pkgrel=1
epoch=
pkgdesc="Client program to transmit local keyboard events over bluetooth."
@@ -19,10 +19,18 @@ backup=()
options=()
install=
changelog=
-source=("$pkgname-$pkgver.tar.bz2")
-md5sums=('d0670498038f11b23415880a873e3f55')
+source=("$url/$pkgname-$pkgver.tar.bz2"
+ "0001-f10-escape.patch")
+md5sums=('70ca8cabf77dbe9b70ba62808942dc29'
+ 'c8b66710490670e33a1821b95b3b3c59')
noextract=()
+prepare() {
+ cd "$srcdir/"
+
+ patch -p1 < "$srcdir/0001-f10-escape.patch"
+}
+
build() {
cd "$srcdir/"
@@ -33,7 +41,6 @@ package() {
cd "$srcdir/"
install -Dm755 hidclient "$pkgdir/usr/bin/hidclient"
- install -Dm644 hid-sdp-record.bin "$pkgdir/etc/bluetooth/hid-sdp-record.bin"
}
# vim:set ts=2 sw=2 et: