summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c5bb0a793914..39e5bdaf5e8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,21 @@
# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
pkgname=hilbish
-pkgver=0.4.0
+pkgver=0.5.0
pkgrel=1
pkgdesc="A shell written in Go and extended with Lua"
arch=('x86_64' 'aarch64')
-url="https://github.com/hilbis/hilbish"
+url="https://github.com/rosettea/hilbish"
license=('MIT')
depends=('readline' 'lua51-lunacolors-git')
makedepends=('go>=1.16')
optdepends=('lua')
install="$pkgname.install"
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('5c6e9bc93df00c8225f34dfa51c5dc4f52f526d23b34785854fd6019a3e7d77e')
+sha256sums=('4c0a5608445ea5fc5ee1c7db8825ea7e19e6363624d94e84523a11141f127ba3')
prepare() {
- mv "Hilbish-$pkgver" "$pkgname-$pkgver"
- cd "$pkgname-$pkgver"
+ cd "Hilbish-$pkgver"
sed -i '\|/etc/shells|d' Makefile
}
@@ -27,12 +26,12 @@ build() {
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- cd "$pkgname-$pkgver"
+ cd "Hilbish-$pkgver"
make build
}
package() {
- cd "$pkgname-$pkgver"
+ cd "Hilbish-$pkgver"
DESTDIR="$pkgdir/" make install
install -Dm 444 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
install -Dm 444 README.md -t "$pkgdir/usr/share/doc/$pkgname/"