summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d803b1b897c..001b34ec3454 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,27 @@
# Maintainer: Torsten Keßler <t dot kessler at posteo dot de>
# Contributor: Markus Näther <naetherm@informatik.uni-freiburg.de>
pkgname=hipcub
-pkgver=5.2.3
+pkgver=5.3.0
pkgrel=1
pkgdesc='Header-only library on top of rocPRIM or CUB'
arch=('x86_64')
url='https://docs.amd.com/bundle/hipCUB-release-rocm-rel-5.2/page/introduction.html'
license=('custom')
depends=('rocprim')
-makedepends=('cmake' 'rocm-cmake' 'git' 'hip')
+makedepends=('rocm-cmake' 'git' 'hip')
_git='https://github.com/ROCmSoftwarePlatform/hipCUB'
source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
-sha256sums=('cab929f10c649f8fd76df989a16d0cd9301bc6aaad91cd2f84498c831378d559')
+sha256sums=('4016cfc240b3cc1a97b549ecc4a5b76369610d46247661834630846391e5fad2')
_dirname="$(basename $_git)-$(basename "${source[0]}" ".tar.gz")"
build() {
# -fcf-protection is not supported by HIP, see
- # https://docs.amd.com/bundle/ROCm-Compiler-Reference-Guide-v5.2/page/Appendix_A.html
+ # https://docs.amd.com/bundle/ROCm-Compiler-Reference-Guide-v5.3/page/Appendix_A.html
- CXX=/opt/rocm/bin/hipcc \
CXXFLAGS="${CXXFLAGS} -fcf-protection=none" \
cmake -Wno-dev -S "$_dirname" \
-DCMAKE_INSTALL_PREFIX=/opt/rocm \
+ -DCMAKE_CXX_COMPILER=/opt/rocm/bin/hipcc \
-Damd_comgr_DIR=/opt/rocm/lib/cmake/amd_comgr
}