summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 19 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c972033f87fb..c0e2d04b5260 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,34 @@
-# Maintainer: Muratcan Sisek <mail@muratcansimsek.com.tr>
+# Maintainer: Alex Tharp <toastercup@gmail.com>
+# Original Maintainer: Muratcan Sisek <mail@muratcansimsek.com.tr>
pkgname=hiri
-pkgver=1.0.7.0
+pkgver=1.2.3.0
pkgrel=1
-pkgdesc="An Exchange ready mail client aiming to replace Outlook (QT5)"
+pkgdesc="A cross-platform, Exchange-ready email client aiming to replace Outlook"
arch=('x86_64')
url="https://www.hiri.com/"
license=('custom')
+provides=('hiri')
+conflicts=('hiri')
depends=('python-pyqt5'
- 'qt5-webkit'
- 'python-pyenchant')
+ 'qt5-webkit'
+ 'python-pyenchant')
install=$pkgname.install
-source=('https://feedback.hiri.com/downloads/Hiri-'$arch'-'$pkgver'.tar.gz'
- 'hiri.desktop'
- 'Hiri-EULA'
- 'hiri.sh')
-sha512sums=('4696b1fb777d66d66110b4612dc74f8491d9ebd868ae8c713cc04dd4ce05854a52349c32f8c22fec4578a8d6ac3e4243c1b75efba7a83812c4b66587a11e334b'
- '5afa589faa4d31419f74650d2d7735c430d236d5fe264b000154eeaeface527547db8816a45485e7d144a3151e8d5edc847fe2b5e2eb7f447ae91285064afb7d'
- 'c1640c1a3430418a72cbaa169c790a18f0571613c1c4791f8c4c12289bbc10ca361bb322baa79a1b183411bc378f7e51ed235ef49f6ace0aab92367321444b81'
+source=('https://feedback.hiri.com/dist/downloads/Hiri-'$arch'-'$pkgver'.tar.gz'
+ 'https://feedback.hiri.com/dist/downloads/license.txt'
+ 'hiri.desktop'
+ 'hiri.sh')
+sha512sums=('3b080f78f74ffccaebfc6719b9f23ef542f4bc4ac0dba48c01f44697323600cb284c0774356f07cd9d61cd28127422eed5abc111e1e9f5422846aff3115cff26'
+ 'ae8274026cb1b68f9b3f4cb66348952e19e31d477602a3d6d529121010260727824d0a060303e10fa8c5661f0b336ceabb0b472ad1cb74835ff5d6f3d3d53636'
+ 'cc50dc92bd28bb3178a857b436d0958077b1f6ede643a65cd5d6b900dc05d6b73f04ea1fe76af6298841bffb08f8d4fd94796b9511feeeaf2f3de8a6e163304c'
'cafbf1f327618cb1d8914babf9cc9c2013b5db27df2a463329f9d366952c5ee592e946e727f991c8f7f558bdf7e625b91e0e029fa193650c197c6c9c6a57676d')
build () {
- cd hiri
- cp /usr/lib/python3.6/lib-dynload/_ssl.cpython-36m-x86_64-linux-gnu.so _ssl.cpython-36m-x86_64-linux-gnu.so
-
+ cd hiri_"$pkgver"
}
+
package() {
install -d "$pkgdir"/opt
- cp -rup "hiri" "$pkgdir"/opt/$pkgname
+ cp -rup "hiri_$pkgver" "$pkgdir"/opt/$pkgname
install -d "$pkgdir"/usr/bin
ln -s /opt/$pkgname/hiri.sh "$pkgdir"/usr/bin/hiri
@@ -38,6 +40,5 @@ package() {
install -d "$pkgdir"/usr/share/icons/hicolor/128x128/apps
ln -s /opt/$pkgname/hiri.png "$pkgdir"/usr/share/icons/hicolor/128x128/apps/$pkgname.png
- install -Dm644 Hiri-EULA "$pkgdir"/usr/share/licenses/$pkgname/EULA
-
+ install -Dm644 license.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}