summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e033152f25d9..2110849aa5ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgbase=hlbsp
pkgname=${_pkgbase}-git
-pkgver=0.4.6
+pkgver=r150.a5e59d9
pkgrel=1
pkgdesc="Half-Life's .BSP maps viewer."
arch=('any')
@@ -10,13 +10,12 @@ url="https://github.com/r4v3n6101/hlbsp"
license=('GPL')
makedepends=('rust' 'cargo' 'git')
provides=("${_pkgbase}")
-conflicts=("${_pkgbase}")
source=("${pkgname}::git+https://github.com/r4v3n6101/hlbsp")
md5sums=('SKIP')
pkgver() {
cd "${srcdir}/${pkgname}"
- git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {