summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dbe2628461e1..5e7aad17e4ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Dino Morelli <dino@ui3.info>
pkgname=hlint-static-git
-pkgver=3.8.r17.gbaf62009
+pkgver=3.8.r19.g323eb45e
pkgrel=1
pkgdesc='Haskell source code suggestions'
arch=('x86_64')
@@ -20,6 +20,12 @@ pkgver() {
git describe --tags --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$pkgname"
+
+ stack config set resolver lts-22.19 # ghc-9.6.4
+ echo 'compiler: ghc-9.6.5' >> stack.yaml
+}
build() {
cd "$pkgname"