summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6ba42f751cd3..0de068ba40c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=hm-git
-pkgver=16.22.r2.g9ea3a3e9
+pkgver=16.23.r32.g6169f170
pkgrel=1
pkgdesc='HEVC Test Model - the reference software for HEVC (git version)'
arch=('x86_64')
@@ -12,10 +12,13 @@ makedepends=('git' 'cmake' 'lsb-release' 'openmp')
provides=('hm' 'hm-svn')
conflicts=('hm' 'hm-svn')
replaces=('hm-svn')
-source=('git+https://vcgit.hhi.fraunhofer.de/jct-vc/HM.git')
-sha256sums=('SKIP')
+source=('git+https://vcgit.hhi.fraunhofer.de/jct-vc/HM.git'
+ '010-hm-disable-werror.patch')
+sha256sums=('SKIP'
+ '26ed4fb40812ecfce04b1301dc159fb2a575ece22a3532fe991f72e0f4e9488a')
prepare() {
+ patch -d HM -Np1 -i "${srcdir}/010-hm-disable-werror.patch"
cp -a HM HM-highbit
}
@@ -51,7 +54,6 @@ package() {
install -D -m755 "HM-highbit/bin/${_file}" "${pkgdir}/usr/bin/${_file/Static/HighBitDepthStatic}"
done < <(find HM-highbit/bin -maxdepth 1 -type f -executable -print0 | sed -z 's|HM\-highbit/bin||')
- install -D -m644 HM/README -t "${pkgdir}/usr/share/doc/${pkgname}"
install -D -m644 HM/doc/*.pdf -t "${pkgdir}/usr/share/doc/${pkgname}"
install -D -m644 HM/COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}