summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dbee0a92f793..6a8ecf414582 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,25 @@
-# $Id:$
-# Maintainer: Abhishek Dasgupta <abhidg@gmail.com>
+# Maintainer: kleintux <reg-archlinux AT klein DOT tuxli DOT ch>
+# Contributor: Abhishek Dasgupta <abhidg@gmail.com>
pkgname=hodie
pkgver=1.4
-pkgrel=1
+pkgrel=2
pkgdesc="Prints the date in Latin."
-url="http://hodie.sourceforge.net"
-arch=(i686 x86_64)
+url="https://hodie.sourceforge.net"
+arch=('i686' 'x86_64')
license=('custom')
-source=(http://downloads.sourceforge.net/hodie/$pkgname-$pkgver.tar.gz
+source=(https://downloads.sourceforge.net/hodie/${pkgname}-${pkgver}.tar.gz
Makefile.diff)
+sha256sums=('ef553078f457f65068712a8ac5cf9361431f227546c30ea9396cd12c83dc4266'
+ '9626b332d17127339fbba032f4a6356bd6e3a5fe70e8f8111bbc1046ad622b71')
+
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "${pkgname}-${pkgver}"
patch -p0 -i ../Makefile.diff || return 1
make || return 1
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
make DESTDIR="$pkgdir" install
}
-md5sums=('fd3f23135fd74e17516aa0c08757edd9'
- 'c65fae177943033f068cdeca16f7bd49')