summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 19 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4bde0a76a7e0..e5a2045b49a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,55 @@
pkgname=home-assistant-service-pip
_serviceName=hass
pkgdesc='Self installing package of Home Assistant using pip'
-pkgver=6
-pkgrel=2
+pkgver=8
+pkgrel=1
arch=('any')
url='https://home-assistant.io/'
license=(APACHE)
depends=(
gcc
+ pkgconf
+ python-aiodiscover
python-aiohttp
python-aiohttp-cors
python-astral
python-async-timeout
+ python-atomicwrites
python-attrs
python-awesomeversion
python-bcrypt
+ python-build
python-certifi
python-ciso8601
python-cryptography
+ python-dateutil
python-defusedxml
+ python-fnvhash
+ python-home-assistant-bluetooth
python-httpx
+ python-ifaddr
+ python-installer
python-jinja
+ python-lru-dict
python-mutagen
+ python-orjson
python-pillow
python-pip
+ python-pynacl
python-pyjwt
python-pytz
python-requests
python-ruamel-yaml
python-slugify
python-sqlalchemy
+ python-typing_extensions
python-voluptuous
python-voluptuous-serialize
python-wheel
python-yaml
python-yarl
python-zeroconf
+ python-setuptools
python
rust
)
@@ -44,11 +58,11 @@ optdepends=(
'openzwave: Z-Wave integration'
)
source=("${_serviceName}.service" "${_serviceName}-update.service" "${_serviceName}.sysusers" "${_serviceName}.tmpfiles" "${_serviceName}.env")
-sha256sums=('927203a5ef14fa74ff14e089a31ee9f24b750b4b939ef402f350b85df976f6dd'
- 'f1a47e94b6c85571dc2a2aec8a917f85692f77d7c4ff3063f4676c5b062988c8'
+sha256sums=('c4d15648e7e325b6f695c528912ec6f440064efde44715d81a8f3dd6d4210ef8'
+ '2f1ad3bfa518a12695265463790bdf30b9389312f0194d601723a05036948f50'
'ee49a7bb8ce2cf2bb34f53708d205aea4e16c25c1cb9d3925d562286ab499852'
'ac019d391343821e63039b0f55eb7d5129acb3e3a04e7c3fb47870a773e3079b'
- '635bd69c105ee08fe3b60c613519dcc10833288c9c04536dbe0dedf50f3e12d0')
+ '6532f9bd1027f7c40f825d95d6cf5b7ca0ea8be9c71c173f02490a49e07572f4')
backup=("etc/${_serviceName}.env")
install="${_serviceName}.install"
provides=('home-assistant')