summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7f5fdce824c1..f4aba005d398 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
pkgname="hornet-git"
_pkgname="hornet"
_branch="main"
-pkgver="1.0.1"
-pkgrel="2"
+_pkgver="1.0.1"
+pkgver="1.0.1.r0.gb185dbcf"
+pkgrel="1"
pkgdesc="HORNET is a powerful IOTA fullnode software"
arch=('x86_64')
url="https://github.com/gohornet/hornet"
@@ -17,6 +18,11 @@ sha256sums=('SKIP'
backup=('etc/hornet/config.json' 'etc/hornet/config_as.json' 'etc/hornet/config_chrysalis_testnet.json' 'etc/hornet/peering.json' 'etc/hornet/profiles.json')
install=$_pkgname.install
+pkgver() {
+ cd ${_pkgname}
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
cd ${srcdir}/hornet