summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5cd5d0455aa6..397ecf2856bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: setBoolean <setboolean@icloud.com>
pkgname="hornet-git"
_pkgname="hornet"
-_branch="master"
-pkgver="0.5.6"
+_branch="main"
+pkgver="1.0.1"
pkgrel="1"
pkgdesc="HORNET is a powerful IOTA fullnode software"
arch=('x86_64')
@@ -13,24 +13,23 @@ makedepends=('go' 'git')
source=("git://github.com/gohornet/$_pkgname.git#branch=$_branch"
"$_pkgname.service")
sha256sums=('SKIP'
- '56c5ecbdb4691465d0cdc3d5c95ea885c38281e1c721aa7153fd226755ea997b')
-backup=('etc/hornet/config.json' 'etc/hornet/config_comnet.json' 'etc/hornet/config_devnet.json' 'etc/hornet/mqtt_config.json' 'etc/hornet/peering.json' 'etc/hornet/profiles.json')
+ '06f5b5c6d3a7384610438f73ff82f6ba669c4d6274b70ffd0784b0011cc9b560')
+backup=('etc/hornet/config.json' 'etc/hornet/config_as.json' 'etc/hornet/config_chrysalis_testnet.json' 'etc/hornet/peering.json' 'etc/hornet/profiles.json')
install=$_pkgname.install
build() {
cd ${srcdir}/hornet
- # Build with optimized PoWd
- go build -tags=pow_avx}
+ # Build with rocksdb
+ go build -tags=rocksdb
}
package() {
# Install files
install -Dm600 ${srcdir}/hornet/config.json ${pkgdir}/etc/hornet/config.json
- install -Dm600 ${srcdir}/hornet/config_comnet.json ${pkgdir}/etc/hornet/config_comnet.json
- install -Dm600 ${srcdir}/hornet/config_devnet.json ${pkgdir}/etc/hornet/config_devnet.json
- install -Dm600 ${srcdir}/hornet/mqtt_config.json ${pkgdir}/etc/hornet/mqtt_config.json
+ install -Dm600 ${srcdir}/hornet/config_as.json ${pkgdir}/etc/hornet/config_as.json
+ install -Dm600 ${srcdir}/hornet/config_chrysalis_testnet.json ${pkgdir}/etc/hornet/config_chrysalis_testnet.json
install -Dm600 ${srcdir}/hornet/peering.json ${pkgdir}/etc/hornet/peering.json
install -Dm600 ${srcdir}/hornet/profiles.json ${pkgdir}/etc/hornet/profiles.json
install -D ${srcdir}/hornet/hornet ${pkgdir}/usr/bin/hornet