summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8fb9ee75c00b..fc7a4e84e051 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ arch=('any')
url="https://github.com/KDAB/hotspot"
license=('GPL2')
depends=('qt5-base>=5.6.0' 'libelf' 'elfutils' 'threadweaver' 'ki18n' 'kconfig' 'kio' 'kitemviews' 'kcoreaddons' 'kitemmodels' 'kconfigwidgets' 'solid')
-makedepends=('cmake>=3.1.0' 'extra-cmake-modules')
+makedepends=('cmake>=3.1.0' 'extra-cmake-modules' 'desktop-file-utils')
provides=("${pkgname}")
conflicts=("${pkgname}-git")
source=("https://github.com/KDAB/hotspot/releases/download/v${pkgver}/hotspot-v${pkgver}.tar.gz")
@@ -23,4 +23,5 @@ build() {
package() {
cd "${pkgname}-v${pkgver}"
make DESTDIR="${pkgdir}/" install
+ desktop-file-install hotspot.desktop --dir="${pkgdir}/usr/share/applications/"
}