summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e6db0268764e..4bafa74f3ed7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
# Contributor: Jon Gjengset <jon@thesquareplanet.com>
pkgname=hotspot-git
-pkgver=v1.4.0.r41.gff86112
+pkgver=1.4.1.r225.g89c3808
pkgrel=1
pkgdesc="The Linux perf GUI for performance analysis"
arch=('any')
url="https://github.com/KDAB/hotspot"
license=('GPL2')
-depends=('elfutils' 'kcoreaddons' 'kddockwidgets' 'ki18n' 'kconfig' 'kio' 'kitemviews' 'kitemmodels' 'kconfigwidgets' 'kparts' 'libelf' 'qt5-base>=5.6.0' 'solid' 'threadweaver')
+depends=('elfutils' 'kcoreaddons5' 'kddockwidgets' 'ki18n5' 'kconfig5' 'kio5' 'kitemviews5' 'kitemmodels5' 'kconfigwidgets5' 'kparts5' 'libelf' 'qt5-base>=5.6.0' 'solid5' 'threadweaver5')
makedepends=('git' 'cmake>=3.1.0' 'extra-cmake-modules' 'desktop-file-utils')
optdepends=('rustc-demangle>=0.1.18-2: rustc symbols demangling')
provides=("${pkgname%-git}")
@@ -18,7 +18,7 @@ sha256sums=('SKIP')
pkgver() {
cd "${pkgname%-git}"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {