summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e710894994c7..d0a304115b78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,27 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=htslib-git
-pkgver=1.10.2.r134.ge9447f86
-pkgrel=2
+pkgver=1.16.r3.g50361863
+pkgrel=1
pkgdesc="C library for high-throughput sequencing data formats"
arch=('i686' 'x86_64')
url="https://github.com/samtools/htslib"
license=('custom')
depends=('glibc' 'bzip2' 'curl' 'openssl' 'xz')
makedepends=('git')
-provides=('htslib')
+provides=("htslib=$pkgver")
conflicts=('htslib')
options=('staticlibs')
source=("git+https://github.com/samtools/htslib.git")
sha256sums=('SKIP')
+prepare() {
+ cd "htslib"
+
+ git submodule update --init --recursive --remote
+}
+
pkgver() {
cd "htslib"