summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 13 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e929448039e7..b3fb286ed9df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,25 @@
# Maintainer: Owen Trigueros <owentrigueros@gmail.com>
pkgname=httpdirfs
-pkgver=1.2.0
-pkgrel=1
+pkgver=1.2.5
+pkgrel=2
pkgdesc="A filesystem which allows you to mount HTTP directory listings"
-arch=('any')
+arch=('x86_64')
url="https://github.com/fangfufu/httpdirfs"
license=('GPL')
-depends=('gumbo-parser' 'fuse2' 'openssl')
-makedepends=('gumbo-parser' 'fuse2' 'openssl')
-source=("https://github.com/fangfufu/$pkgname/archive/$pkgver.tar.gz")
-md5sums=("5c9c31c39217da0a9ff44b4cae5704eb")
+depends=('gumbo-parser' 'fuse2' 'curl' 'expat')
+makedepends=('help2man' 'doxygen' 'graphviz')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/fangfufu/$pkgname/archive/$pkgver.tar.gz")
+md5sums=("77910de057b196ed7b3714f7a0698203")
-prepare() {
- cd "$pkgname-$pkgver"
-
- # Replace /usr/local prefix with /usr
- sed -i 's/^prefix ?= \/usr\/local/prefix ?= \/usr/' Makefile
-}
build() {
- cd "$pkgname-$pkgver"
- make
+ cd "$pkgname-$pkgver"
+ make man
+ make doc
+ make
}
package() {
- cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir" install
+ cd "$pkgname-$pkgver"
+ make prefix=/usr DESTDIR="$pkgdir" install
}