summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7b76024c0a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Owen Trigueros <owentrigueros@gmail.com>
+
+pkgname=httpdirfs
+pkgver=1.1.10
+pkgrel=1
+pkgdesc="A filesystem which allows you to mount HTTP directory listings"
+arch=('any')
+url="https://github.com/fangfufu/httpdirfs"
+license=('GPL')
+depends=('gumbo-parser' 'fuse2' 'openssl')
+makedepends=('gumbo-parser' 'fuse2' 'openssl')
+source=("https://github.com/fangfufu/$pkgname/archive/$pkgver.tar.gz")
+md5sums=("cfe5321a3de14cade2ce7bcbfcfde018")
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ # Replace /usr/local prefix with /usr
+ sed -i 's/^prefix ?= \/usr\/local/prefix ?= \/usr/' Makefile
+}
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}