summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e950305886b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jaime Martínez Rincón <jaime(at)jamezrin(dot)name>
+
+pkgname=httptoolkit
+pkgver=0.1.7
+pkgrel=1
+pkgdesc="Beautiful, cross-platform & open-source HTTP(S) proxy, analyzer and client."
+arch=("x86_64")
+url="https://httptoolkit.tech/"
+license=('GPL3')
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/httptoolkit/httptoolkit-desktop/releases/download/v${pkgver}/httptoolkit_${pkgver}_amd64.deb")
+noextract=()
+md5sums=("12150a7e58dc432a4df47a2ef3b0fc67")
+validpgpkeys=()
+
+package() {
+ # Extract package fs from deb
+ bsdtar -O -xf "httptoolkit_${pkgver}_amd64.deb" data.tar.xz | bsdtar -C "${pkgdir}" -xJf -
+
+ # Set all directories to 755 mode
+ find "${pkgdir}" -type d -exec chmod 755 {} +
+}