summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 14f13008dd57..7764684f7450 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: max.bra <max dot bra at alice dot it>
pkgname=hub-kids
-pkgver=1.0
+pkgver=6.3.300
pkgrel=1
pkgdesc="La piattaforma facile, gratuita e innovativa per la didattica digitale."
arch=('x86_64')
@@ -19,21 +19,24 @@ optdepends=(
)
options=(!strip)
-_debname=hubkids-1.0_amd64.deb
+_debname=HUB-Kids.deb
-source=(http://www.mondadorieducation.it/media/contenuti/appdilettura/kidslinux.zip)
-md5sums=('4497dfe4b6e2516c11e3ae1480a01c25')
+source=(https://bce.mondadorieducation.it/media_educar/contenuti/appdilettura/kidslinux.zip)
+sha256sums=('79ad6f3cf6667adc163d04b9995489d10cde6b374dc0128bd81fd034d704dc80')
prepare() {
cd "$srcdir"
msg2 "Decompressing Debian package..."
ar xv "${_debname}" > /dev/null
- tar -xf data.tar.xz > /dev/null
+ tar -xf data.tar.zst > /dev/null
- find ./{etc,usr} -type d -exec chmod 755 '{}' \;
+ #find ./{etc,usr} -type d -exec chmod 755 '{}' \;
+ find ./usr -type d -exec chmod 755 '{}' \;
+ chmod 755 ./usr/local/bin/hubkids/hub-kids
}
package() {
cd "$srcdir"
- cp -dpr --no-preserve=ownership {opt,usr} "$pkgdir"
+ #cp -dpr --no-preserve=ownership {opt,usr} "$pkgdir"
+ cp -dpr --no-preserve=ownership ./usr "$pkgdir"
}