summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8c32493157c2..601552073463 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,31 @@
# Contributor: Samuel Damashek <samuel dot damashek at gmail dot com>
# Contributor: Alex Xu <alex_y_xu dot yahoo at ca>
pkgname=huggle
-pkgver=3.4.10
+pkgver=3.4.12
pkgrel=1
pkgdesc="Anti-vandalism tool for use on MediaWiki-based projects"
arch=('i686' 'x86_64')
url="https://en.wikipedia.org/wiki/Wikipedia:Huggle"
license=('GPL')
depends=('qt5-multimedia' 'qt5-webengine' 'yaml-cpp')
-makedepends=('cmake' 'ninja')
+makedepends=('cmake')
+conflicts=('libircclient') # A different, unrelated, libircclient
source=(
"https://github.com/huggle/huggle3-qt-lx/releases/download/${pkgver}/${pkgname}_${pkgver}.tar.gz"
- "huggle-yaml.patch"
"huggle-extensions.patch"
+ "huggle-desktop.patch"
)
-sha256sums=('7dbf2c943f80eac551839535df68d1af4c19d52a026a9140a1b2fcf63f5a2249'
- 'e66bb7ba73b72b08d478715d44baf096c87291e05997ad4786c1515b6574f2bb'
- '823cbf583c00722bfe5ecd74a57ee7e3ef942ecb95a1704e65c226e7a2624497')
+b2sums=('876040712fd59a2efc1f5cc20af1fc9583c9fe13213a03cdc7ca2d90da3880b88c531b112693414e595398d09af1875e73d2a828b5835227a41cb0c4df90ee37'
+ 'e37d338085329911277cabd58108a0be5114b2c3b0469d0e3ed4bfbabda02c85315698c1ce466cb3c9bb25adb4ba208f69a134b4eb9079a2f70b8a36815f077a'
+ '4fa21457d39061bbba01c2e5f5ac9d6d703b56103fac82e48cff09d94b5ca4fe9a912756dad2c7c90079e556814654730b0c18f97f93de11b25b32ac740367ff')
prepare() {
cd "${pkgname}_${pkgver}"
# Patch extension directory to /usr/lib/huggle/extensions (T251049)
patch --forward --strip=1 --input="../huggle-extensions.patch"
- # Backport dependency fix from master, remove in 3.4.11
- patch --forward --strip=1 --input="../huggle-yaml.patch"
+ # Fix icon in huggle.desktop
+ patch --forward --strip=1 --input="../huggle-desktop.patch"
+ echo "+archlinux.${pkgrel}" >> src/huggle_core/version.txt
}
build() {
@@ -46,4 +48,6 @@ build() {
package() {
make DESTDIR="$pkgdir/" -C build install
+
+ install -Dm644 "${pkgname}_${pkgver}/src/huggle_res/Resources/huggle3_newlogo.png" "$pkgdir/usr/share/pixmaps/huggle.png"
}