summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 28 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9de01e6f921c..4535c6e18e1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,40 +2,44 @@
pkgname=hunspell-ko
pkgver=0.7.92
-pkgrel=3
-pkgdesc="Korean dictionary for hunspell"
+pkgrel=4
+pkgdesc="Korean hunspell dictionary"
arch=('any')
url='https://github.com/spellcheck-ko/hunspell-dict-ko'
license=('GPL3')
-depends=('hunspell>=1.3.1')
-makedepends=('python-yaml')
-
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/spellcheck-ko/hunspell-dict-ko/archive/${pkgver}.tar.gz")
-sha1sums=('41085dac1529224d96bfef13fa7fc836aeee5bda')
-build() {
- cd "$srcdir/hunspell-dict-ko-$pkgver"
- make VERSION=$pkgver DESTDIR="$pkgdir" PREFIX=/usr
-}
+makedepends=('qt5-webengine')
+optdepends=('hunspell: the spell checking libraries and apps')
+source=(https://github.com/spellcheck-ko/hunspell-dict-ko/releases/download/${pkgver}/ko-aff-dic-${pkgver}.zip)
+sha512sums=('300e574c7221841801f0d4b114abaa3b15196b69cb25f98ed784c820d125bd60e6fe6ca6cc76dca07de9382e957acd4bc337fa87b84f809b13f703ebe47baa45')
package() {
- cd "$srcdir/hunspell-dict-ko-$pkgver"
- install -dm755 "${pkgdir}/usr/share/hunspell"
- install -m644 ko.dic "${pkgdir}"/usr/share/hunspell
- install -m644 ko.aff "${pkgdir}"/usr/share/hunspell
- pushd "$pkgdir"/usr/share/hunspell
- for file in ko.*; do
- ln -s ${file} ko_KR."${file#*.}"
- done
+ cd "$srcdir/ko-aff-dic-$pkgver"
+ install -vDm 644 ko.dic ko.aff -t "$pkgdir/usr/share/hunspell"
+
+ pushd "$pkgdir/usr/share/hunspell/"
+ ko_KR_aliases="ko_KR"
+ for lang in $ko_KR_aliases; do
+ ln -s ko_KR.aff $lang.aff
+ ln -s ko_KR.dic $lang.dic
+ done
popd
-# symlinks
+ # Install webengine dictionaries
+ install -d "$pkgdir"/usr/share/qt/qtwebengine_dictionaries/
+ for _file in "$pkgdir"/usr/share/hunspell/*.dic; do
+ _filename="$(basename "$_file")"
+ qwebengine_convert_dict "$_file" "$pkgdir"/usr/share/qt/qtwebengine_dictionaries/${_filename/\.dic/\.bdic}
+ done
+
+ # myspell symlinks
install -dm755 "${pkgdir}"/usr/share/myspell/dicts
pushd "$pkgdir"/usr/share/myspell/dicts
- for file in "${pkgdir}"/usr/share/hunspell/*; do
- ln -sv /usr/share/hunspell/$(basename $file) .
- done
+ for dict in "${pkgdir}"/usr/share/hunspell/*; do
+ ln -sv /usr/share/hunspell/$(basename $dict) .
+ done
popd
-# licenses
+ # licenses
install -Dm644 LICENSE.md $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 LICENSE.GPL-3 $pkgdir/usr/share/licenses/$pkgname/LICENSE.GPL-3
}