summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4cd341f67837..c4ca5ec820df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
-# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+# Contributor: Dimitris Kiziridis <ragouel at outlook dot com>
# Contributor: Jean Lucas <jean@4ray.co>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=hunter
pkgver=1.3.5
-pkgrel=2
+pkgrel=3
pkgdesc='Ranger-like CLI file browser written in Rust'
arch=('i686' 'x86_64')
-url='https://github.com/rabite0/hunter'
+url='https://github.com/nanoctr/hunter'
license=('custom:WTFPL')
provides=('hunter')
depends=('gst-plugins-base-libs' 'libsixel')
-makedepends=('rustup'
+makedepends=('git'
+ 'rustup'
'gst-plugins-good'
'gst-plugins-bad'
'gst-plugins-ugly')
@@ -31,18 +33,18 @@ optdepends=('gst-plugins-good: Media support'
'poppler: PDF support'
'mupdf-tools: PDF support'
'fzf: Default file finder')
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('f0f9bf2b4defeeb83e339b984407eb717cb1cb9fffb358e65780e89aa72c906a')
+source=("git+${url}.git#commit=17946cf")
+sha256sums=('SKIP')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}"
rustup override set nightly
cargo build --release
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}"
install -D target/release/hunter{,-media} -t "${pkgdir}"/usr/bin
install -Dm644 README.md -t "${pkgdir}"/usr/share/doc/hunter
install -Dm644 LICENSE -t "${pkgdir}"/usr/share/licenses/hunter
-} \ No newline at end of file
+}