summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 233def0c30bb..ec58e8a78455 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,23 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=hunter-holy
-pkgver=1.2.3
+pkgver=1.3.0
pkgrel=1
pkgdesc='ranger-like file browser written in Rust (holy branch)'
arch=(i686 x86_64)
url=https://github.com/rabite0/hunter
license=(WTFPL)
-depends=(file xdg-utils gst-plugins-bad gst-plugins-ugly gst-libav)
-makedepends=(rust-nightly)
-optdepends=('nerd-fonts-complete: supported icon pack'
+depends=(xdg-utils gst-plugins-base-libs)
+makedepends=(rustup)
+optdepends=('gst-plugins-good: media support'
+ 'gst-plugins-bad: media support'
+ 'gst-plugins-ugly: media support'
+ 'gst-libav: media support'
+ 'libsixel: media support'
+ 'nerd-fonts-complete: supported icon pack'
'bat: syntax highlighting'
'highlight: syntax highlighting'
+ 'libarchive: archive support'
'p7zip: archive support'
'w3m: HTML support'
'links: HTML support'
@@ -21,17 +27,18 @@ optdepends=('nerd-fonts-complete: supported icon pack'
'mupdf-tools: PDF support')
provides=(hunter)
conflicts=(hunter)
-source=($url/archive/v$pkgver-holy.tar.gz)
-sha512sums=('805561a541e6aa95eff1a64d7e686564d5727fe5179f813dd618a3382d1605057d73a3bd1d58311fd755b78c25295a7215f8aa01447c10074cfc70599c6c84d5')
+source=(hunter-holy-$pkgver.tar.gz::$url/archive/v$pkgver-holy.tar.gz)
+sha512sums=('81fac08545350eac39a5b7d2b3e258a7d01c75ec8158292200d1505cd459004fa6d30d546b3bc5b5f2ab48d96bb5c7597b2a2a4fc3ac2fade941a283d2af396e')
build() {
cd hunter-$pkgver-holy
- cargo +nightly build --release
+ rustup override set nightly
+ cargo build --release
}
package() {
cd hunter-$pkgver-holy
- install -D target/release/{hunter,preview-gen} extra/scope.sh -t "$pkgdir"/usr/bin
+ install -D target/release/hunter{,-media} -t "$pkgdir"/usr/bin
install -Dm 644 README.md -t "$pkgdir"/usr/share/doc/hunter
install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/hunter
}