summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 56cf36324824..736e7146b047 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,20 @@
# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
pkgname=hw-probe
-pkgver=r3.0015b3d
+pkgver=1.2
pkgrel=1
pkgdesc="Tool to probe for hardware, check its operability and upload result to the Linux hardware DB: http://linux-hardware.org"
arch=('any')
url="https://github.com/linuxhw/hw-probe"
license=('GPLv2')
-makedepends=('git')
-source=("git+$url")
+source=("$url/archive/$pkgver.tar.gz")
md5sums=('SKIP')
-depends=('perl>=5' 'hwinfo' 'curl' 'dmidecode' 'pciutils' 'usbutils')
+depends=('perl>=5' 'hwinfo' 'curl' 'dmidecode' 'pciutils' 'usbutils' 'net-tools')
optdepends=('hdparm' 'smartmontools' 'inxi' 'pnputils')
provides=('hw-probe')
-pkgver() {
- cd "${srcdir}/hw-probe"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
package() {
- cd "${srcdir}/hw-probe"
- install -Dm755 hw-probe.pl "${pkgdir}/usr/bin/${provides[0]}"
+ cd "$srcdir"/hw-probe-$pkgver
+ install -dm755 "$pkgdir"/usr
+ make install prefix="$pkgdir"/usr
}