summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e1aa32292f38..83cfad5345cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,28 @@
pkgname=hyperglot
pkgver=0.2.9
-pkgrel=2
+pkgrel=3
pkgdesc='A database and tools for detecting language support in fonts'
arch=(any)
url="https://github.com/rosettatype/$pkgname"
-license=('GPL3')
-_py_deps=(click fonttools yaml unicodedata2 colorlog)
+license=(GPL3)
+_py_deps=(click
+ colorlog
+ fonttools
+ unicodedata2
+ yaml)
depends=(python ${_py_deps[@]/#/python-})
-makedepends=('python-setuptools')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+makedepends=(python-setuptools)
+_archive="$pkgname-$pkgver"
+source=("$_archive.tar.gz::$url/archive/$pkgver.tar.gz")
sha256sums=('0dc1795f275c11a112a2da01c1b9f50d22f9c58439732738cfbb74679e7e4db9')
build() {
- cd "$pkgname-$pkgver"
+ cd "$_archive"
python setup.py build
}
package() {
- cd "$pkgname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd "$_archive"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}