summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 16 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 62ba8544eea9..d54ba855c08b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,8 @@
pkgname=hyperkeys-bin
_appname=HyperKeys
pkgver=1.3.0
-pkgrel=4
+_electronversion=20
+pkgrel=5
pkgdesc="Unleash you keyboard shorcuts"
arch=('x86_64')
url="https://hyperkeys.xureilab.com/"
@@ -12,7 +13,7 @@ license=('GPL3')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
- 'electron20'
+ "electron${_electronversion}"
'libx11'
'gdk-pixbuf2'
'libxext'
@@ -31,19 +32,29 @@ depends=(
'xdotool'
'perl'
'python'
+ 'nodejs'
)
makedepends=(
'squashfuse'
)
+options=(
+ '!emptydirs'
+ '!strip'
+)
source=(
"${pkgname%-bin}-${pkgver}.AppImage::${_ghurl}/releases/download/v${pkgver}/${_appname}-${pkgver}.AppImage"
- "${pkgname%-bin}.sh")
+ "${pkgname%-bin}.sh"
+)
sha256sums=('2884e6025aa4dfee198f1279584e8ec798d8f9519cbe8c6ed1f4648b26e63711'
- '5d04f8d8b55d211a4174ce1201307c1bdd004080b032d5c1da3e0100180ee2c8')
+ '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
build() {
+ sed -e "s|@electronversion@|${_electronversion}|g" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@appasar@|app|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
- sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ sed "s|AppRun --no-sandbox|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
find "${srcdir}/squashfs-root/resources" -type d -exec chmod 755 {} \;
}
package() {