summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 9 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d54ba855c08b..34f0e5eb60f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,35 +4,27 @@ pkgname=hyperkeys-bin
_appname=HyperKeys
pkgver=1.3.0
_electronversion=20
-pkgrel=5
+pkgrel=6
pkgdesc="Unleash you keyboard shorcuts"
arch=('x86_64')
url="https://hyperkeys.xureilab.com/"
_ghurl="https://github.com/xurei/hyperkeys"
-license=('GPL3')
+license=('GPL-3.0-only')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
- 'libx11'
- 'gdk-pixbuf2'
- 'libxext'
- 'libdbusmenu-glib'
- 'gtk2'
'dbus-glib'
- 'libxcb'
- 'expat'
- 'pango'
- 'cairo'
- 'at-spi2-core'
+ 'libdbusmenu-glib'
'gtk3'
+ 'gtk2'
'java-runtime'
- 'libxmu'
- 'libdbusmenu-gtk3'
- 'xdotool'
'perl'
'python'
'nodejs'
+ 'libdbusmenu-gtk3'
+ 'libxmu'
+ 'xdotool'
)
makedepends=(
'squashfuse'
@@ -46,11 +38,11 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('2884e6025aa4dfee198f1279584e8ec798d8f9519cbe8c6ed1f4648b26e63711'
- '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
+ '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app|g" \
+ -e "s|@runname@|app|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null