summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD96
1 files changed, 96 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02bd4a811ee6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,96 @@
+# Maintainer: Aleksana QwQ <me@aleksana.moe>
+# Contributor: ThatOneCalculator <kainoa@t1c.dev>
+
+_pkgname="hyprland"
+pkgname="${_pkgname}-hidpi-xprop-git"
+pkgver=r1918.1030325
+pkgrel=1
+pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks."
+arch=(any)
+url="https://github.com/hyprwm/Hyprland"
+license=('BSD')
+depends=(
+ libxcb
+ xcb-proto
+ xcb-util
+ xcb-util-keysyms
+ libxfixes
+ libx11
+ libxcomposite
+ xorg-xinput
+ libxrender
+ pixman
+ wayland-protocols
+ cairo
+ pango
+ polkit
+ glslang
+ libinput
+ libxcb
+ libxkbcommon
+ opengl-driver
+ pixman
+ wayland
+ xcb-util-errors
+ xcb-util-renderutil
+ xcb-util-wm
+ seatd
+ vulkan-icd-loader
+ vulkan-validation-layers
+ xorg-xwayland-hidpi-xprop)
+makedepends=(
+ git
+ cmake
+ ninja
+ gcc
+ gdb
+ meson
+ vulkan-headers
+ wayland-protocols
+ xorgproto)
+source=("${_pkgname}::git+https://github.com/hyprwm/Hyprland.git"
+ "https://gitlab.freedesktop.org/lilydjwg/wlroots/-/commit/6c5ffcd1fee9e44780a6a8792f74ecfbe24a1ca7.patch")
+conflicts=("${_pkgname}")
+provides=(hyprland)
+sha256sums=('SKIP'
+ 'a37e441c309b35e5d9b5c5c637c96729c5348a523a7eaa25c6e24b1fcc3521a6')
+options=(!makeflags !buildflags !strip)
+
+pkgver() {
+ cd "$_pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ git submodule update --init
+
+ cd subprojects/wlroots
+ git revert -n 18595000f3a21502fd60bf213122859cc348f9af
+ patch -Np1 < "${srcdir}"/6c5ffcd1fee9e44780a6a8792f74ecfbe24a1ca7.patch
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ make fixwlr
+ cd "./subprojects/wlroots/" && meson build/ --prefix="${srcdir}/tmpwlr" --buildtype=release && ninja -C build/ && mkdir -p "${srcdir}/tmpwlr" && ninja -C build/ install && cd ../../
+ make protocols
+ make release
+ cd ./hyprctl && make all && cd ..
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ mkdir -p "${pkgdir}/usr/share/wayland-sessions"
+ mkdir -p "${pkgdir}/usr/share/hyprland"
+ install -Dm755 build/Hyprland -t "${pkgdir}/usr/bin"
+ install -Dm755 hyprctl/hyprctl -t "${pkgdir}/usr/bin"
+ install -Dm644 assets/*.png -t "${pkgdir}/usr/share/hyprland"
+ install -Dm644 example/hyprland.desktop -t "${pkgdir}/usr/share/wayland-sessions"
+ install -Dm644 example/hyprland.conf -t "${pkgdir}/usr/share/hyprland"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${_pkgname}"
+ install -Dm755 ../tmpwlr/lib/libwlroots.so.11032 -t "${pkgdir}/usr/lib"
+}