summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8fde3bc7e869..f80583fef0ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,11 @@
# Maintainer: q234 rty <q23456yuiop at gmail dot com>
# Contributor: ThatOneCalculator <kainoa@t1c.dev>
# Contributor: lilydjwg <lilydjwg@gmail.com>
+# Contributor: FabioLolix
_pkgname="hyprland"
pkgname="${_pkgname}-hidpi-xprop-git"
-pkgver=0.28.0.r34.3f7f4207
+pkgver=0.28.0.r81.41d9b6f0
pkgrel=1
pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks."
arch=("i686" "x86_64" "arm" "armv6h" "armv7h" "aarch64")
@@ -39,7 +40,8 @@ depends=(
xcb-util-wm
seatd
vulkan-icd-loader
- xorg-xwayland-hidpi-xprop)
+ xorg-xwayland-hidpi-xprop
+)
makedepends=(
git
cmake
@@ -48,7 +50,8 @@ makedepends=(
meson
vulkan-headers
wayland-protocols
- xorgproto)
+ xorgproto
+)
source=("${_pkgname}::git+https://github.com/hyprwm/Hyprland.git"
"git+https://gitlab.freedesktop.org/wlroots/wlroots.git"
"git+https://github.com/hyprwm/hyprland-protocols.git"
@@ -57,7 +60,7 @@ source=("${_pkgname}::git+https://github.com/hyprwm/Hyprland.git"
"0002-Fix-configure_notify-event.patch"
"0003-Fix-size-hints-under-Xwayland-scaling.patch")
conflicts=("${_pkgname}")
-provides=(hyprland)
+provides=("${_pkgname}=${pkgver}")
sha256sums=('SKIP'
'SKIP'
'SKIP'
@@ -88,6 +91,8 @@ prepare() {
patch -Np1 -i "${srcdir}"/0003-Fix-size-hints-under-Xwayland-scaling.patch
cd "${srcdir}/${_pkgname}"
make fixwlr
+ # respect build flags to allow full RELRO
+ sed -i '/CXX/ s|)|) $(CXXFLAGS)|;/CXX/ s|$| $(LDFLAGS)|;' hyprctl/Makefile
}
build() {
@@ -118,6 +123,6 @@ package() {
cp -R src ${pkgdir}/usr/include/hyprland/
cp -R ../tmpwlr/include/* ${pkgdir}/usr/include/hyprland/wlroots/
find ${pkgdir}/usr/include/hyprland/ -type f ! -name '*.h*' -delete
- cp protocols/*-protocol.h ${pkgdir}/usr/include/hyprland/protocols
+ cp protocols/*-protocol.h ${pkgdir}/usr/include/hyprland/protocols
install -Dm644 build/hyprland.pc -t "${pkgdir}/usr/share/pkgconfig"
}