summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7957112f9680..01e3761ba328 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
_pkgname="hyprland"
pkgname="${_pkgname}-hidpi-xprop-git"
-pkgver=0.32.3.r21.91d6be1f
-pkgrel=1
+pkgver=0.33.1.r5.a794eecd
+pkgrel=2
pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks."
arch=("i686" "x86_64" "arm" "armv6h" "armv7h" "aarch64")
url="https://github.com/hyprwm/Hyprland"
@@ -49,6 +49,7 @@ makedepends=(
meson
wayland-protocols
xorgproto
+ tomlplusplus
)
source=("${_pkgname}::git+https://github.com/hyprwm/Hyprland.git"
"git+https://gitlab.freedesktop.org/wlroots/wlroots.git"
@@ -101,6 +102,7 @@ package() {
meson install -C subprojects/wlroots/build --destdir "${pkgdir}/tmpwlr"
install -Dm755 build/Hyprland -t "${pkgdir}/usr/bin"
install -Dm755 build/hyprctl/hyprctl -t "${pkgdir}/usr/bin"
+ install -Dm755 build/hyprpm/hyprpm -t "${pkgdir}/usr/bin"
install -Dm644 assets/*.png -t "${pkgdir}/usr/share/hyprland"
install -Dm644 example/hyprland.desktop -t "${pkgdir}/usr/share/wayland-sessions"
install -Dm644 example/hyprland.conf -t "${pkgdir}/usr/share/hyprland"