summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 16 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 55557dab97b8..6c1fb71c814f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,20 +8,31 @@
_pluginame=i2pbote
pkgname=i2p-plugin-${_pluginame}
pkgver=0.4.3
-pkgrel=1
+pkgrel=2
pkgdesc="A distributed email client for I2P"
arch=('any')
url="http://bote.i2p/"
license=('GPLv3')
groups=('i2p-plugins')
depends=('i2p')
-makedepends=('unzip')
+makedepends=('unzip' 'java-runtime-common')
provides=('i2pbotes')
# get this from http://bote.i2p/i2pbote.su3
source=("file://${_pluginame}.su3")
noextract=("file://${_pluginame}.su3")
+install="${_pluginame}.install"
sha256sums=('19ae8e09f932d111dc8016e9a3c4f6fa78c059a650d3d735de08d5c1233b7780')
+_unpack_dir() {
+ # use this to unpack the .war/.jar files. I2P does this automaticly on install
+ # but it will not work otherwise
+ local indir="$@"
+ for file in $indir/*.pack;do
+ unpack200 $file ${file%.pack}
+ rm $file
+ done
+}
+
prepare() {
cd "${srcdir}"
@@ -37,7 +48,9 @@ prepare() {
package() {
cd "${srcdir}"
- mkdir -p "${pkgdir}/opt/i2p/plugins/.i2p/"
+ mkdir -p "${pkgdir}/opt/i2p/.i2p/plugins/"
cp -Ra "i2p" "${pkgdir}/opt/i2p/.i2p/plugins/${_pluginame}"
+ _unpack_dir "${pkgdir}/opt/i2p/.i2p/plugins/${_pluginame}/lib"
+ _unpack_dir "${pkgdir}/opt/i2p/.i2p/plugins/${_pluginame}/console/webapps"
}