summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD61
1 files changed, 35 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 30f499e95549..4618b5556511 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,50 @@
-# Contributor: Jan Oliver Oelerich <janoliver@oelerich.org>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Jan Oliver Oelerich <janoliver@oelerich.org>
pkgname=i3pystatus-git
pkgdesc="i3status replacement written in python for the i3 window manager"
pkgver=3.35.r370.gac71437
-pkgrel=1
-conflicts=('i3pystatus')
-provides=('i3pystatus')
-arch=('i686' 'x86_64')
+pkgrel=2
+arch=('any')
+url="https://github.com/enkore/i3pystatus"
license=('MIT')
-depends=('python')
-optdepends=('python-pyalsaaudio: For the alsa module.',
- 'python-dbus: For the thunderbird or now_playing modules.',
- 'python-psutil: For the mem, membar or network_traffic modules.',
- 'python-netifaces: For the network or wireless modules.',
- 'python-beautifulsoup4: For the parcel module.',
- 'python-cssselect: For the parcel module.',
- 'python-lxml: For the parcel module.',
- 'python-pywapi: For the weather module.',
- 'python-basiciw: For the wireless module.'
- 'python-colour: For the pulseaudio module.')
+depends=('python>=3.6')
+optdepends=(
+ 'python-pyalsaaudio: For the alsa module.',
+ 'python-dbus: For the thunderbird or now_playing modules.',
+ 'python-psutil: For the mem, membar or network_traffic modules.',
+ 'python-netifaces: For the network or wireless modules.',
+ 'python-beautifulsoup4: For the parcel module.',
+ 'python-cssselect: For the parcel module.',
+ 'python-lxml: For the parcel module.',
+ 'python-pywapi: For the weather module.',
+ 'python-basiciw: For the wireless module.'
+ 'python-colour: For the pulseaudio module.')
makedepends=('git' 'python-setuptools')
-url="https://github.com/enkore/i3pystatus.git"
-source=('git+https://github.com/enkore/i3pystatus.git')
-_gitname="i3pystatus"
+checkdepends=('python-pytest-runner' 'python-mock')
+provides=('i3pystatus')
+conflicts=('i3pystatus')
+source=("$pkgname::git+$url")
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/$_gitname"
- echo $(git describe --always --long | sed 's/^[v]//;s/-/-r/' | tr - .)
+ cd "$pkgname"
+ git describe --long --tags | sed 's/-/.r/;s/-/./'
}
build() {
- cd "$srcdir/$_gitname"
- python setup.py build
+ cd "$pkgname"
+ python setup.py build
+}
+
+check() {
+ cd "$pkgname"
+ python setup.py pytest
}
package() {
- cd "$srcdir/$_gitname"
- python setup.py install --root="$pkgdir" --optimize=1
-}
+ cd "$pkgname"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm 644 MIT-LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 README.rst CONTRIBUTORS -t "$pkgdir/usr/share/doc/$pkgname/"
+}