summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..17534693bf14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: TheCynicalTeam <TheCynicalTeam@github.com>
+# Contributor: TheCynicalTeam <TheCynicalTeam@github.com>
+pkgname=i3session
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Remembers what's running in your i3 workspaces by saving a session file"
+arch=('any')
+url="https://github.com/TheCynicalTeam/$pkgname"
+license=('GPL')
+depends=(python2-xdg python-i3-py i3-wm xorg-xprop)
+makedepends=('git')
+source=("git://github.com/TheCynicalTeam/$pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git log -1 --format="%cd.g%h" --date=short | sed 's/-/./g'
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ sed -i '1 s:/python:/env python2:' "$pkgname"
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+}