summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f777b596d4bd..b93151cd13ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gaƫl PORTAY <gael.portay@gmail.com>
pkgname=iamroot
-pkgver=14
+pkgver=15
pkgrel=1
pkgdesc='Emulating the syscall chroot(2) in an unpriviliged process'
arch=('x86_64')
@@ -18,9 +18,16 @@ makedepends=('lib32-glibc'
checkdepends=('shellcheck')
options=('!strip')
source=("https://github.com/gportay/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('4ea344b21249225c1852271f4983d72351df1516eacaae2042f663cbc55d48e7')
+sha256sums=('b62d5e033f04359f9d5450f45111f3f8b676eb14a8d8fdb0bd8382e48398bee1')
validpgpkeys=('8F3491E60E62695ED780AC672FA122CA0501CA71')
+# Fixes:
+#
+# $ ish
+# /bin/bash: symbol lookup error: /usr/lib/iamroot/libiamroot.so: undefined symbol: _Unwind_Resume
+CFLAGS="${CFLAGS//-fexceptions/}"
+export CFLAGS
+
prepare() {
cd "$pkgname-$pkgver"
ln -sf support/linux.mk makefile