summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 777ffeae9ae8..d207ca2abf49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -40,10 +40,17 @@ install=citrix-client.install
package() {
cd "${srcdir}"
ICAROOT=/opt/Citrix/ICAClient
+ if [[ $CARCH == 'i686' ]]
+ then
+ ICADIR="$srcdir/linuxx86/linuxx86.cor"
+ elif [[ $CARCH == 'x86_64' ]]
+ then
+ ICADIR="$srcdir/linuxx64/linuxx64.cor"
+ fi
mkdir -p ${pkgdir}$ICAROOT
- cd "$srcdir/linuxx64/linuxx64.cor"
+ cd $ICADIR
install -m755 wfica *.so *.DLL AuthManagerDaemon PrimaryAuthManager ServiceRecord selfservice ${pkgdir}$ICAROOT
# copy directories