summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD112
1 files changed, 112 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fdd5f98c83ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,112 @@
+# former Maintainer: Daniele Vazzola <daniele.vazzola@gmail.com>
+# Contributor: CiarĂ¡n Coffey <ciaran@ccoffey.ie>
+# Contributor: Matthew Gyurgyik <matthew@pyther.net>
+pkgname=icaclient-old
+realpkgname=icaclient
+pkgver=13.4
+pkgrel=1
+pkgdesc="Citrix Receiver for x86_64 (64bit) Linux (ICAClient) Version 13.4"
+arch=('x86_64' 'i686')
+url="http://www.citrix.com/English/ps2/products/product.asp?contentID=1689163&ntref=prod_top"
+license=('custom:Citrix')
+depends=('alsa-lib' 'libvorbis' 'curl' 'gtk2' 'libpng12' 'libxml2' 'libxaw' 'libxext' 'libxft'
+ 'libxinerama' 'libxmu' 'libxp' 'libxpm' 'libxt' 'ca-certificates')
+makedepends=('automake' 'autoconf' 'wget')
+optdepends=(
+ 'xerces-c: gtk2 configuration manager'
+ 'webkitgtk2: gtk2 selfservice/storefront ui')
+conflicts=('bin32-citrix-client' 'citrix-client')
+options=(!strip)
+backup=("opt/Citrix/ICAClient/config/appsrv.ini" "opt/Citrix/ICAClient/config/wfclient.ini" "opt/Citrix/ICAClient/config/module.ini")
+source_url32="http:$(curl -L -silent 'https://www.citrix.com/downloads/citrix-receiver/legacy-receiver-for-linux/receiver-for-linux-latest-13-4.html' | awk -F 'rel=\"' '/linuxx86-/ {print $2}'| awk -F'"' '{print $1}'| sed '/^$/d' |uniq)"
+source_url64="http:$(curl -L -silent 'https://www.citrix.com/downloads/citrix-receiver/legacy-receiver-for-linux/receiver-for-linux-latest-13-4.html' | awk -F 'rel=\"' '/linuxx64-/ {print $2}'| awk -F'"' '{print $1}'| sed '/^$/d' |uniq)"
+source=('configmgr.desktop' 'conncenter.desktop' 'selfservice.desktop' 'wfica.desktop' 'wfica.sh' 'wfica_assoc.sh')
+source_i686=($realpkgname-x86-$pkgver.tar.gz::$source_url32)
+source_x86_64=($realpkgname-x64-$pkgver.tar.gz::$source_url64)
+md5sums=('71aca6257f259996ac59729604f32978'
+ 'a38c3f844a0fefe8017a25bee213b843'
+ '0e92c33b3fcc99b04269787da2984809'
+ '1f214f6f456f59afd1a3275580f4240e'
+ '59f8e50cc0e0c399d47eb7ace1df5a32'
+ 'dca5a1f51449ef35f1441b900d622276')
+md5sums_x86_64=('e3fd715e0f8cd72715a51d8593394b19')
+md5sums_i686=('486dc36b74adf0a017bddc42a01a2db3')
+install=citrix-client.install
+
+package() {
+ cd "${srcdir}"
+ ICAROOT=/opt/Citrix/ICAClient
+ if [[ $CARCH == 'i686' ]]
+ then
+ ICADIR="$srcdir/linuxx86/linuxx86.cor"
+ elif [[ $CARCH == 'x86_64' ]]
+ then
+ ICADIR="$srcdir/linuxx64/linuxx64.cor"
+ fi
+
+ mkdir -p ${pkgdir}$ICAROOT
+
+ cd $ICADIR
+ install -m755 wfica *.so *.DLL AuthManagerDaemon PrimaryAuthManager ServiceRecord selfservice ${pkgdir}$ICAROOT
+
+ # copy directories
+ cp -r ./config/ ${pkgdir}$ICAROOT
+ cp -r ./gtk/ ${pkgdir}$ICAROOT
+ cp -r ./help/ ${pkgdir}$ICAROOT
+ cp -r ./keyboard/ ${pkgdir}$ICAROOT
+ cp -r ./keystore/ ${pkgdir}$ICAROOT
+ cp -r ./lib/ ${pkgdir}$ICAROOT
+ cp -r ./icons/ ${pkgdir}$ICAROOT
+ cp -r ./nls/ ${pkgdir}$ICAROOT
+ cp -r ./site/ ${pkgdir}$ICAROOT
+ cp -r ./usb/ ${pkgdir}$ICAROOT
+ cp -r ./util/ ${pkgdir}$ICAROOT
+
+ # Install License
+ install -m644 -D nls/en.UTF-8/eula.txt \
+ "${pkgdir}$ICAROOT/eula.txt"
+
+ # create /config/.server to enable user customization using ~/.ICACLient/ overrides. Thanks Tomek
+ touch ${pkgdir}$ICAROOT/config/.server
+
+ # Extract system ca-certificates and install in the Citrix cacerts directory
+ cp /etc/ca-certificates/extracted/tls-ca-bundle.pem ${pkgdir}$ICAROOT/keystore/cacerts/
+ cd ${pkgdir}$ICAROOT/keystore/cacerts/
+ awk 'BEGIN {c=0;} /BEGIN CERT/{c++} { print > "cert." c ".pem"}' < tls-ca-bundle.pem
+
+ # The following 32-bit library causes false namcap errors
+ # rm util/libgstflatstm.32.so
+
+ # Install wrapper script
+ install -m755 ${srcdir}/wfica.sh ${pkgdir}$ICAROOT/wfica.sh
+
+ # Dirty Hack
+ # wfica expects {module,wfclient,apssrv}.ini in $ICAROOT/config
+ # sadly these configs differ slightly by locale
+ lang=${LANG%%_*}
+ if [[ ! -d ${pkgdir}/$ICAROOT/nls/$lang ]]; then
+ lang='en'
+ fi
+ cp ${pkgdir}$ICAROOT/nls/$lang/module.ini ${pkgdir}/$ICAROOT/config/
+ cp ${pkgdir}$ICAROOT/nls/$lang/appsrv.template ${pkgdir}/$ICAROOT/config/appsrv.ini
+ cp ${pkgdir}$ICAROOT/nls/$lang/wfclient.template ${pkgdir}/$ICAROOT/config/wfclient.ini
+
+ # Copy Firefox plugin into plugin directory
+ mkdir -p "${pkgdir}/usr/lib/mozilla/plugins"
+ ln -s "$ICAROOT/npica.so" "${pkgdir}"/usr/lib/mozilla/plugins/npica.so
+ cd "${srcdir}"
+ # install freedesktop.org files
+ install -Dm644 wfica.desktop "${pkgdir}/usr/share/applications/wfica.desktop"
+ install -Dm644 conncenter.desktop "${pkgdir}/usr/share/applications/conncentre.desktop"
+ install -Dm644 configmgr.desktop "${pkgdir}/usr/share/applications/configmgr.desktop"
+ install -Dm644 selfservice.desktop "${pkgdir}/usr/share/applications/wfcmgr.desktop"
+ # install scripts
+ install -Dm755 wfica.sh "${pkgdir}$ICAROOT"
+ install -Dm755 wfica_assoc.sh "${pkgdir}$ICAROOT"
+
+ # make certificates available
+ ln -s "${pkgdir}/usr/share/ca-certificates/trust-source/*" "${pkgdir}/opt/Citrix/ICAClient/keystore/cacerts/"
+ c_rehash "${pkgdir}/opt/Citrix/ICAClient/keystore/cacerts/"
+
+}
+