summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d48e9a5ae803..ff7e6caacc32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,15 +8,15 @@ pkgver() {
git -C "$_pkgname" describe --tags | sed 's/v\?\([^-]\+\)-/\1.r/;s/-g/./'
}
pkgver=6.0.8.r26.499b891
-pkgrel=1
+pkgrel=2
pkgdesc='Desktop integration for webapps'
url="https://github.com/peppermintos/$_pkgname"
arch=('any')
license=('GPL2')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}" "$_pkgname")
+conflicts=("${pkgname%-git}" "$_pkgname")
makedepends=('git')
depends=('python-requests' 'python-beautifulsoup4' 'python-gobject' 'python-lxml')
@@ -30,14 +30,14 @@ sha256sums=('SKIP'
prepare() {
cd "$_pkgname"
# patch browser binary filenames to match Archlinux packages
- patch -Np1 <"../$_pkgname.patch"
+ patch --no-backup-if-mismatch -Np1 <"../$_pkgname.patch"
# delete PeppermintOS specific assets
rm -r usr/lib
}
package() {
cd "$_pkgname"
- cp -a --no-preserve=ownership usr "$pkgdir/"
+ cp -a --no-preserve=o usr "$pkgdir/"
install -Dm644 README.md -t"$pkgdir/usr/share/doc/$_pkgname/"
}