summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 58e6170d2bd2..ad18331129a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,44 @@
# Maintainer : Kr1ss $(echo \<kr1ss+x-yandex+com\>|sed s/\+/./g\;s/\-/@/)
-_pkgname=ice
+_name=ice
pkgname=ice-ssb-git
pkgver() {
- git -C "$_pkgname" describe --tags | sed 's/v\?\([^-]\+\)-/\1.r/;s/-g/./'
+ git -C "$_name" describe --tags | sed 's/v\?\([^-]\+\)-/\1.r/;s/-g/./'
}
-pkgver=6.0.8.r26.499b891
-pkgrel=3
+pkgver=6.0.8.r30.5ddfc8e
+pkgrel=1
pkgdesc='Desktop integration for webapps'
-url="https://github.com/peppermintos/$_pkgname"
+url="https://github.com/peppermintos/$_name"
arch=('any')
license=('GPL2')
-provides=("${pkgname%-git}" "$_pkgname")
-conflicts=("${pkgname%-git}" "$_pkgname")
+provides=("${pkgname%-git}" "$_name")
+conflicts=("${pkgname%-git}" "$_name")
makedepends=('git')
depends=('python-requests' 'python-beautifulsoup4' 'python-gobject' 'python-lxml')
optdepends=('brave' 'firefox' 'chromium' 'google-chrome' 'vivaldi')
-source=("git+$url.git" "$_pkgname.patch")
+source=("git+$url.git" "$_name.patch")
sha256sums=('SKIP'
- 'b7ca85f38fb7dd9369d069ab1969d082fda6f23f16218fe13c3b69c9f886f8b6')
+ '1b3ba9c290faa8a9f2c8caf6c754378ac7ae82cf1117318a115e075b800c10d3')
prepare() {
- cd "$_pkgname"
+ cd "$_name"
# patch browser binary filenames to match Archlinux packages
- patch --no-backup-if-mismatch -Np1 <"../$_pkgname.patch"
+ patch --verbose -Np1 <"../$_name.patch"
# delete PeppermintOS specific assets
rm -r usr/lib
}
package() {
- cd "$_pkgname"
+ cd "$_name"
cp -a --no-preserve=o usr "$pkgdir/"
- install -Dm644 README.md -t"$pkgdir/usr/share/doc/$_pkgname/"
+ install -Dm644 README.md -t"$pkgdir/usr/share/doc/$_name/"
}