summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 18 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 160a8ba46e58..631910cf269d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,32 @@
-# Maintainer: Helder Bertoldo <helder.bertoldo@gmail.com>
-# Contributor:
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Helder Bertoldo <helder.bertoldo@gmail.com>
-_author=santileortiz
-_gitname=Iconoscope
-_auxname=iconoscope
-pkgname=("${_auxname}-git")
-pkgver=latest
+pkgname=iconoscope-git
+pkgver=0.9.3.r6.g03dada1
pkgrel=1
pkgdesc="Explore the system's icon theme database written in Vala designed for Pantheon Shell"
-arch=('i686' 'x86_64')
-url="https://github.com/${_author}/${_gitname}"
-license=('GPL3')
-depends=('gtk3' 'vala' 'granite')
-optdepends=()
-makedepends=('git' 'meson' 'ninja')
-provides=("${_auxname}")
-conflicts=("${_auxname}")
-source=("git+${url}.git")
+arch=(any)
+url="https://github.com/santileortiz/Iconoscope"
+license=(GPL3)
+depends=(libgranite.so python)
+makedepends=(git vala)
+provides=(iconoscope)
+conflicts=(iconoscope)
+source=("iconoscope::git+${url}.git")
md5sums=('SKIP')
pkgver() {
- cd "${_gitname}"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ cd ${pkgname/-git/}
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${_gitname}/"
- meson . _build --prefix=/usr
- ninja -C _build
+ cd ${pkgname/-git/}
+ ./pymk.py iconoscope
}
package() {
- cd "${_gitname}/"
- DESTDIR="${pkgdir}" ninja -C _build install
+ cd ${pkgname/-git/}
+ ./pymk.py install --install_completions --destdir ${pkgdir}/
}