summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 7 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b3014308c570..3a11a754907c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,19 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
+# Contributor: Emanuele 'Lele aka eldios' Calo' <xeldiosx@gmail.com>
+# Contributor: Fabien Devaux <fdev31@gmail.com>
-# Maintainer: Fabien Devaux <fdev31@gmail.com>
pkgname=ideamaker
-pkgver=3.3.0.2343
+pkgver=4.3.2
+pkgverminor=6470
pkgrel=1
-epoch=
pkgdesc="Fast and user friendly 3D slicer for FDM printers"
arch=('x86_64')
url="https://www.raise3d.com/pages/ideamaker"
license=('other')
-groups=()
depends=('mesa-libgl' 'desktop-file-utils')
makedepends=('binutils')
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=("https://s3.amazonaws.com/ideamaker/linux/ideaMaker_${pkgver}-ubuntu_amd64.deb")
-noextract=()
-sha256sums=('2a6cc2856b7ee8aa00f7f2aa57de3d2fc35a5c69e6a3b6c9ffd4572d2ff0c37d')
-validpgpkeys=()
+source_x86_64=("https://download.raise3d.com/ideamaker/release/${pkgver}/ideaMaker_${pkgver}.${pkgverminor}-ubuntu_amd64.deb")
+sha256sums_x86_64=('c7a131e8fa866d793393304e7e676274c57eaa6029751542740bce8abe76126f')
+
package() {
tar xf "$srcdir/data.tar.xz" -C "${pkgdir}"